CISCO CALL MANAGER FULL CONFIG DIRECT TO WAN

This config is taken from a Cisco 2821 Router running CME 10 and IOS 12.4 The CME server is located at 172.25.140.1 on the Data Vlan, and the phones are located at 172.35.140.0/16. Inbound calling was set up with a single DID to extension 1002. The configuration below should be considered a minimum configuration to get your Call Manager system working with SIPTRUNK.com It may need to be modified significantly depending on your circumstances.

***NOTE: To ensure that the URI that is delivered from SIPTRUNK.com contains your DID and not your Trunk #, you must do the following:

1. Login to your SIPTRUNK.com Control Panel

2. Click on "Sip Trunking"

3. Click on "Modify Trunk"

4. Ensure that "Contact Override" is set to "On" ***

 

service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname C2821
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 <YOUR HASHED SECRET>
!
aaa new-model
aaa local authentication attempts max-fail 15
!
!
!
!
!
!
!
aaa session-id common
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 172.25.140.1 172.25.140.10
ip dhcp excluded-address 172.35.140.1 172.35.140.10
!
ip dhcp pool Data
network 172.25.0.0 255.255.0.0
default-router 172.25.140.1
option 66 ip 172.25.140.1
option 150 ip 172.25.140.1
!
ip dhcp pool Voice
network 172.35.0.0 255.255.0.0
default-router 172.35.140.1
option 66 ip 172.35.140.1
option 150 ip 172.35.140.1
!
!
ip name-server 8.8.8.8
ip multicast-routing
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice service voip
ip address trusted list
ipv4 63.247.69.226
ipv4 205.251.137.154
ipv4 <YOUR PUBLIC IP>
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
sip
bind control source-interface GigabitEthernet0/0.25
registrar server expires max 3600 min 120
!
voice class sip-profiles 1
request INVITE sip-header From modify "<sip:<YOUR TRUNK NUMBER>@<YOUR PUBLIC IP>" "<sip:<YOUR TRUNK NUMBER>@gw1.siptrunk.com>"
request INVITE sip-header From modify "<sip:<YOUR TRUNK NUMBER>@172.25.140.1>" "<sip:<YOUR TRUNK NUMBER>@gw1.siptrunk.com>"
!
!
voice register global
mode cme
source-address 172.25.140.1 port 5060
max-dn 40
max-pool 42
tftp-path flash:
create profile sync 000507801600852A
!
voice register dn 1
number 2001
allow watch
name PH-2001
label 2001
mwi
!
voice register dn 2
number 2002
allow watch
name PH-2002
label 2002
mwi
!
voice register dn 3
number 2003
allow watch
name PH-2003
label 2003
mwi
!
voice register dn 4
number 2004
allow watch
name PH-2004
label 2004
mwi
!
voice register dn 5
number 2005
allow watch
name PH-2005
label 2005
mwi
!
voice register dn 6
number 2006
allow watch
name PH-2006
label 2006
mwi
!
voice register dn 7
number 2007
allow watch
name PH-2007
label 2007
mwi
!
voice register dn 8
number 2008
allow watch
name PH-2008
label 2008
mwi
!
voice register dn 9
number 2009
allow watch
name PH-2009
label 2009
mwi
!
voice register dn 10
number 2010
allow watch
name PH-2010
label 2010
mwi
!
!
!
voice translation-rule 5
rule 1 /^.*/ /<YOUR TRUNK NUMBER>/
!
!
voice translation-profile SIPTRUNK-Outgoing
translate calling 5
!
!
voice-card 0
!
!
!
license udi pid CISCO2821 sn <YOUR CISCO SERIAL NUMBER>
username admin privilege 15 password 7 <YOUR HASHED PASSWORD>
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.25
description Data VLAN
encapsulation dot1Q 25
ip address 172.25.140.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.35
description Voice VLAN
encapsulation dot1Q 35
ip address 172.35.140.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/1
ip address <YOUR PUBLIC IP ADDRESS> <YOUR SUBNET MASK>
ip access-group ACL-INFRASTRUCTURE-IN in
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
!
!
ip nat pool ovrld <YOUR PUBLIC IP ADDRESS> <YOUR PUBLIC IP ADDRESS> netmask <YOUR SUBNET MASK>
ip nat inside source list 7 pool ovrld overload
ip nat inside source static udp 172.25.140.1 5060 <YOUR PUBLIC IP ADDRESS> 5060 extendable
ip nat inside source static 172.25.140.1 <YOUR PUBLIC IP ADDRESS> route-map SIP_NAT
ip route 0.0.0.0 0.0.0.0 YOUR GATEWAY IP
!
ip access-list extended ACL-INFRASTRUCTURE-IN
permit tcp host YOUR MANAGEMENT IP any eq 22
permit ip any any
permit icmp host <YOUR PUBLIC IP ADDRESS> any echo
deny tcp any any fragments
deny udp any any fragments
deny icmp any any fragments
deny ip any any fragments
deny ip any any option any-options
deny ip any any ttl lt 6
ip access-list extended UDP_RTP
permit udp any any range 8000 20000
!
access-list 7 permit 0.0.0.1 255.255.255.0
access-list 7 permit 172.25.140.0 0.0.0.254
access-list 7 permit 172.35.140.0 0.0.0.254
access-list 7 permit 172.35.0.0 0.0.254.254
access-list 101 permit udp any any eq domain
access-list 101 permit udp any eq domain any
access-list 140 permit ip host 172.35.140.15 any
access-list 140 permit ip any host 172.35.140.15
access-list 140 permit ip host 172.25.140.1 any
access-list 140 permit ip any host 172.25.140.1
!
!
!
!
route-map SIP_NAT permit 10
match ip address UDP_RTP
!
!
tftp-server flash:/OS79XX.TXT
tftp-server flash:/SIPDefault.cnf
tftp-server flash:/music-on-hold.au
tftp-server flash:/Ringtones/Ringlist.xml alias Ringlist.xml
tftp-server flash:/Ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
tftp-server flash:/Ringtones/Analog1.raw alias Analog1.raw
tftp-server flash:/Ringtones/Analog2.raw alias Analog2.raw
tftp-server flash:/Ringtones/AreYouThere.raw alias AreYouThere.raw
tftp-server flash:/Ringtones/AreYouThereF.raw alias AreYouThereF.raw
tftp-server flash:/Ringtones/Bass.raw alias Bass.raw
tftp-server flash:/Ringtones/CallBack.raw alias CallBack.raw
tftp-server flash:/Ringtones/Chime.raw alias Chime.raw
tftp-server flash:/Ringtones/Classic1.raw alias Classic1.raw
tftp-server flash:/Ringtones/Classic2.raw alias Classic2.raw
tftp-server flash:/Ringtones/ClockShop.raw alias ClockShop.raw
tftp-server flash:/Ringtones/Drums1.raw alias Drums1.raw
tftp-server flash:/Ringtones/Drums2.raw alias Drums2.raw
tftp-server flash:/Ringtones/FilmScore.raw alias FilmScore.raw
tftp-server flash:/Ringtones/HarpSynth.raw alias HarpSynth.raw
tftp-server flash:/Ringtones/Jamaica.raw alias Jamaica.raw
tftp-server flash:/Ringtones/KotoEffect.raw alias KotoEffect.raw
tftp-server flash:/Ringtones/MusicBox.raw alias MusicBox.raw
tftp-server flash:/Ringtones/Piano1.raw alias Piano1.raw
tftp-server flash:/Ringtones/Piano2.raw alias Piano2.raw
tftp-server flash:/Ringtones/Pop.raw alias Pop.raw
tftp-server flash:/Ringtones/Pulse1.raw alias Pulse1.raw
tftp-server flash:/Ringtones/Sax1.raw alias Sax1.raw
tftp-server flash:/Ringtones/Sax2.raw alias Sax2.raw
tftp-server flash:/Ringtones/Vibe.raw alias Vibe.raw
tftp-server flash:/Ringtones/Ring1.raw alias Ring1.raw
tftp-server flash:/Ringtones/Ring2.raw alias Ring2.raw
tftp-server flash:/Ringtones/Ring3.raw alias Ring3.raw
tftp-server flash:/Ringtones/Ring4.raw alias Ring4.raw
tftp-server flash:/Ringtones/Ring5.raw alias Ring5.raw
tftp-server flash:/Ringtones/Ring6.raw alias Ring6.raw
tftp-server flash:/Ringtones/Ring7.raw alias Ring7.raw
tftp-server flash:/SCCP-Phones/P00308010200.bin alias P00308010200.bin
tftp-server flash:/SCCP-Phones/P00308010200.sbn alias P00308010200.sbn
tftp-server flash:/SCCP-Phones/P00308010200.sb2 alias P00308010200.sb2
tftp-server flash:/SCCP-Phones/P00308010200.loads alias P00308010200.loads
tftp-server flash:/SCCP-Phones/SCCP41.9-3-1SR4-1S.loads alias SCCP41.9-3-1SR4-1S.loads
tftp-server flash:/SCCP-Phones/term41.default.loads alias term41.default.loads
tftp-server flash:/SCCP-Phones/term61.default.loads alias term61.default.loads
tftp-server flash:/SCCP-Phones/apps41.9-3-1ES26.sbn alias apps41.9-3-1ES26.sbn
tftp-server flash:/SCCP-Phones/cnu41.9-3-1ES26.sbn alias cnu41.9-3-1ES26.sbn
tftp-server flash:/SCCP-Phones/cvm41sccp.9-3-1ES26.sbn alias cvm41sccp.9-3-1ES26.sbn
tftp-server flash:/SCCP-Phones/dsp41.9-3-1ES26.sbn alias dsp41.9-3-1ES26.sbn
tftp-server flash:/SCCP-Phones/jar41sccp.9-3-1ES26.sbn alias jar41sccp.9-3-1ES26.sbn
tftp-server flash:/SCCP-Phones/SCCP42.9-3-1SR4-1S.loads alias SCCP42.9-3-1SR4-1S.loads
tftp-server flash:/SCCP-Phones/term42.default.loads alias term42.default.loads
tftp-server flash:/SCCP-Phones/term62.default.loads alias term62.default.loads
tftp-server flash:/SCCP-Phones/apps42.9-3-1ES26.sbn alias apps42.9-3-1ES26.sbn
tftp-server flash:/SCCP-Phones/cnu42.9-3-1ES26.sbn alias cnu42.9-3-1ES26.sbn
tftp-server flash:/SCCP-Phones/cvm42sccp.9-3-1ES26.sbn alias cvm42sccp.9-3-1ES26.sbn
tftp-server flash:/SCCP-Phones/dsp42.9-3-1ES26.sbn alias dsp42.9-3-1ES26.sbn
tftp-server flash:/SCCP-Phones/jar42sccp.9-3-1ES26.sbn alias jar42sccp.9-3-1ES26.sbn
tftp-server flash:/SCCP-Phones/SCCP45.9-3-1SR4-1S.loads alias SCCP45.9-3-1SR4-1S.loads
tftp-server flash:/SCCP-Phones/term45.default.loads alias term45.default.loads
tftp-server flash:/SCCP-Phones/term65.default.loads alias term65.default.loads
tftp-server flash:/SCCP-Phones/apps45.9-3-1ES26.sbn alias apps45.9-3-1ES26.sbn
tftp-server flash:/SCCP-Phones/cnu45.9-3-1ES26.sbn alias cnu45.9-3-1ES26.sbn
tftp-server flash:/SCCP-Phones/cvm45sccp.9-3-1ES26.sbn alias cvm45sccp.9-3-1ES26.sbn
tftp-server flash:/SCCP-Phones/dsp45.9-3-1ES26.sbn alias dsp45.9-3-1ES26.sbn
tftp-server flash:/SCCP-Phones/jar45sccp.9-3-1ES26.sbn alias jar45sccp.9-3-1ES26.sbn
!
!
!
control-plane
!
!
!
!
mgcp profile default
!
!
dial-peer voice 2 voip
description **Outgoing calls to SIPTRUNK SIP Trunk**
translation-profile outgoing SIPTRUNK-Outgoing
destination-pattern .T
session protocol sipv2
session target dns:gw1.siptrunk.com
voice-class sip profiles 1
dtmf-relay rtp-nte
codec g711ulaw
no vad
authentication username <YOUR TRUNK NUMBER> password 7 <YOUR TRUNK PASSWORD> realm gw1.siptrunk.com
!
!
num-exp <YOUR DID EX: +15551234567> 1002
sip-ua
credentials username <YOUR TRUNK NUMBER> password 7 <YOUR TRUNK PASSWORD> realm gw1.siptrunk.com
retry invite 2
retry register 10
timers connect 100
registrar 1 dns:gw1.SIPTRUNK expires 360 refresh-ratio 20 auth-realm gw1.siptrunk.com
!
!
!
telephony-service
moh-file-buffer 2000
max-ephones 30
max-dn 50
ip source-address 172.25.140.1 port 2000
cnf-file location flash:
load 7960-7940 P00308010200
load 7941 SCCP41.9-3-1SR4-1S
load 7942 SCCP42.9-3-1SR4-1S
load 7945 SCCP45.9-3-1SR4-1S
load 7961 SCCP41.9-3-1SR4-1S
load 7962 SCCP42.9-3-1SR4-1S
load 7965 SCCP45.9-3-1SR4-1S
max-conferences 8 gain -6
moh music-on-hold.au
multicast moh 239.1.1.1 port 2000 route 172.25.140.1 172.35.140.1
dn-webedit
time-webedit
transfer-system full-consult
!
!
ephone-dn 1
number 1001
label 1001
description Phone 1
name Phone 1
hold-alert 30 originator
!
!
ephone-dn 2
number 1002
label 1002
description Phone 2
name Phone 2
hold-alert 30 originator
!
!
ephone-dn 3
number 1003
label 1003
description Phone 3
name Phone 3
hold-alert 30 originator
!
!
ephone-dn 4
number 1004
label 1004
description Phone 4
name Phone 4
hold-alert 30 originator
!
!
ephone-dn 5
number 1005
label 1005
description Phone 5
name Phone 5
hold-alert 30 originator
!
!
ephone-dn 6
number 1006
label 1006
description Phone 6
name Phone 6
hold-alert 30 originator
!
!
ephone-dn 7
number 1007
label 1007
description Phone 7
name Phone 7
hold-alert 30 originator
!
!
ephone-dn 8
number 1008
label 1008
description Phone 8
name Phone 8
hold-alert 30 originator
!
!
ephone-dn 9
number 1009
label 1009
description Phone 9
name Phone 9
hold-alert 30 originator
!
!
ephone-dn 10
number 1010
label 1010
description Phone 10
name Phone 10
hold-alert 30 originator
!
!
ephone 1
device-security-mode none
mac-address 0013.197E.5391
button 1:1
!
!
!
ephone 2
device-security-mode none
mac-address 0014.1C51.F40C
button 1:2
!
!
!
alias exec con conf t
alias exec sib show ip int brief
alias exec srb show run | b
alias exec sri show run int
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
privilege level 15
transport input telnet ssh
transport output telnet ssh
line vty 5 15
privilege level 15
transport input telnet ssh
transport output telnet ssh
!
scheduler allocate 20000 1000
ntp master 1
end

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk